Urgent Help Can't hear fuel pump prime up


Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Can't hear fuel pump prime up

  1. #1
    Join Date
    Feb 2009
    Location
    baton rouge
    Posts
    2
    Post Thanks / Like

    Hmm2 Can't hear fuel pump prime up

    2005 VTX 1800. When you turn the key on I don't hear the pump prime up. I checked all fuses, I can hear one of the relay's clicking when I turn the key on. I switched both of the relay's and they both click. I am not getting power to the plug under the seat from the pump to the wiring harness. I have a good ground at that point. Any suggestions?

  2. Remove Advertisements
    VTX Cafe
    Advertisements
     

  3. #2
    Join Date
    Jan 2009
    Location
    Saint Paul
    Posts
    512
    Post Thanks / Like
    Check the kill switch.

    With the seat off put your had on the back box that is above the battery. If its working correctly you should feel it click 3-5 seconds after the key is turned on.

    I don't have a schematic for the F but honda wiring is pretty similar for most years.
    You should have 2 wires going to your fuel pump.
    Green--- this is always ground on the bike
    Brown--- this is the pump power feed

    Now when you turn the key on the pump should cycle for 3-5 seconds so you should see voltage there. If not check your kill switch. It must be in the run position.

    If you didn't get any power go to the fuel cut-off relay

    check for voltage on the brown wire again when you turn the key on the pump should cycle for 3-5 seconds so you should see voltage there. if there was no power check the brown with a black stripe wire on the fuel cut-off relay the same way. This wire is fed from the ECM. Warning! You need to disconnect the battery before connecting/disconnecting the ECM connectors or you run the risk of frying the ecm.

  4. #3
    Join Date
    Jul 2008
    Location
    The Wildersville
    Posts
    1,808
    Post Thanks / Like
    Now is that info or what !!!
    Ride on !!!!!

  5. Remove Advertisements
    VTX Cafe
    Advertisements
     

  6. #4
    Join Date
    Oct 2008
    Location
    Niagara
    Age
    55
    Posts
    1,328
    Post Thanks / Like
    Yup prob just the kill switch when he turns the key...

  7. #5
    madmatt's Avatar
    madmatt is offline Senior Member
    Florida Riders Group
    Join Date
    Aug 2008
    Location
    Jacksonville
    Posts
    1,608
    Post Thanks / Like
    Damn X'n you don't play do ya.

  8. #6
    Join Date
    Apr 2010
    Location
    albuquerque
    Posts
    2
    Post Thanks / Like
    my fuel pump wont power up there is power going to the pump but i cant hear it prime when i turn it on i read these posts but nothing about how and if you fixed your pump

  9. #7
    Join Date
    Oct 2008
    Location
    Niagara
    Age
    55
    Posts
    1,328
    Post Thanks / Like
    Ummm real stupid question...

    When the key is on....did you flick your kill switch to on?

  10. #8
    Join Date
    Apr 2010
    Location
    albuquerque
    Posts
    2
    Post Thanks / Like
    yes, but it just makes a clicking sound [n the relay

    I am trying everything before I replace the pump i am getting power to the pump and the kill switch is on the run position i just cant figure out why the pump wont prime could it be my ecm?

  11. #9
    Join Date
    Feb 2009
    Location
    baton rouge
    Posts
    2
    Post Thanks / Like
    Quote Originally Posted by purplerain View Post
    yes, but it just makes a clicking sound [n the relay

    I am trying everything before I replace the pump i am getting power to the pump and the kill switch is on the run position i just cant figure out why the pump wont prime could it be my ecm?
    Try and jump the pump out. Un hook the plug and go straight to your battery. If it doesn't prime like that then u need a new pump. I changed mine out myself. Little messy with all the gas but didn't want to spend 700 on part and labor. Got a factory pump off a website for 450. Hope this helps
    Posted via Mobile Device

  12. #10
    Join Date
    Dec 2016
    Location
    woodstock
    Posts
    1
    Post Thanks / Like
    im having the same problem but there seems to be nothing on the neutral side of the power the indicator light will not even come on i have it narrowed down to either the ecm or the pump i am going to try the direct wire to the pump and im going to also try a friends ecm off of his bike any other suggestions would be appreciated

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. Fuel pump
      By thomas_msmith in forum Honda VTX 1800 Forums
      Replies: 4
      Last Post: 10-14-2008, 12:56 PM
    2. fuel pump
      By thomas_msmith in forum *** The Shop ~ I NEED URGENT MOTORCYCLE HELP!! ***
      Replies: 1
      Last Post: 10-13-2008, 09:25 PM
    3. Question 2003 fuel pump
      By luckyjake in forum Honda VTX 1300 Forums
      Replies: 0
      Last Post: 10-10-2008, 08:24 PM
    4. Fuel pump
      By Jim in forum Honda VTX 1300 Forums
      Replies: 19
      Last Post: 04-03-2008, 01:23 PM

    Bookmarks

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •