Honda VTX 1300 / VTX 1800 Motorcycles Forum banner

backfiring

  1. Honda VTX 1300 Forums
    So I've got a 2007 VTX 1300C with HardChrome pipes and stock airbox. Had it rejetted last summer (I believe to 195) and it ran like a top. Still does. Took it on a bunch of rides this summer with no issues. But now, all of a sudden, I'm getting backfires on the slightest deceleration. Shift...
  2. Honda VTX 1800 Forums
    Sorry for posting so much! This is the third mystery issue I have dealt with in the last two weeks. I hope I can solve this like the other two and do less wrenching and more riding! This issue now is this: JUST off of idle, at super low RPM, after just starting to pull the throttle, my bike has...
  3. Honda VTX 1300 Forums
    Just wondering if anyone has experience this. It's a buzz-sound when the bike is running/ignition is on. When the bike is stopped it makes a "click" sound every time I apply the break handle. The noise comes from the handle area near the break-fluid reservoir. This happened after I removed the...
  4. Honda VTX 1800 Forums
    Okay, my problem has continued to progress to the point where my bike became unable to ride today. It's a 2002 VTX 1800, with a set of Bubs straight pipes, KN filter in stock housing and a Power Commander. Bike has 11k on the odometer and is ridden to my office (six miles round trip along...
  5. Exhaust
    I just bought a 2007 X 1300 with 1,900 miles on it(picking it up in 2 weeks). The previous owner installed DG Hard Krome K-2's himself. After looking for reviews on this exhaust (our of sheer curiosity), I found a review by the guy I'm buying this bike from! It has me slightly concerned...
  6. Honda VTX 1300 Forums
    Thank you to all who got me through 90% of my issues with the cold starting. I got the A/F tool, made some adjustments, swapped out the plugs and life with no choke is good. Now, the second problem I have still looms. After riding a while and stopping for a 10-15 minute break, the bike will...
  7. Honda VTX 1300 Forums
    I made the adjustments to the A/F screw (2 1/2 turns out) and put in the Champion RA8HC plugs and now I do not need any choke to start when cold and it runs beautifully after about 1 to 1 1/2 minutes (Ocala,FL and 90 degrees). The second part of my issue is still not resolved. After running...
Top