Honda VTX 1300 / VTX 1800 Motorcycles Forum banner

1 - 9 of 9 Posts

·
Sparky
Joined
·
49 Posts
Discussion Starter #1
Ok guys! I have a 2005 1300c and the taillight portion of the light works but when i hit the brakes it does not get any brighter meaning the brake light isnt working. I have installed the kuryakyn license plate bracket with the kury turn signals and i have put new levers on the front. Could one of the switches to turn the brake light on be bad?? I have checked fuses and bulbs and wiring and they all look good. Any help would be appreciated.... Kinda sucks to ride with no brake light. Thanks!
 

·
Let's Get Ready To Rumble
Joined
·
5,240 Posts
My first guess would be that the wiring is not correct. If it really is, and the bulbs are fine and the fuses are fine, I'd take off the new part and replace the old setup to see if it works like that. At least you will have narrowed down the problem. But I still suspect the wiring is crossed . . .
 

·
Darkside Pastor & Addict
Joined
·
4,151 Posts
Ok guys! I have a 2005 1300c and the taillight portion of the light works but when i hit the brakes it does not get any brighter meaning the brake light isnt working. I have installed the kuryakyn license plate bracket with the kury turn signals and i have put new levers on the front. Could one of the switches to turn the brake light on be bad?? I have checked fuses and bulbs and wiring and they all look good. Any help would be appreciated.... Kinda sucks to ride with no brake light. Thanks!
The bulb may look good but still one of the filaments could be bad. Simple way to check is to replace the bulb before digging into the other stuff. Now I know you know this but please do not ride until you get it fixed. It's is dangerous enough out there with all the lights working.

PDave:patriot:
 

·
Sparky
Joined
·
49 Posts
Discussion Starter #4
I have undone whatever i did to the bike and still nothing. The wiring going to the taillight has been untouched. I have replaced the bulb and the fuse and still nothing.
 

·
Desert Recluse
Joined
·
1,517 Posts
I have undone whatever i did to the bike and still nothing. The wiring going to the taillight has been untouched. I have replaced the bulb and the fuse and still nothing.
Did you check for a sticking brake switch?
 

·
Sparky
Joined
·
49 Posts
Discussion Starter #6
I took everything apart tonight and it seems to be a bad switch on the footbrake. Handbrake lights up the taillight and if i touch the wires for the foot switch together they work but i f i put the switch back together it doesnt work. And yes it was not stuck just not working...
 

·
Premium Member
Joined
·
9,717 Posts
Make sure the brake switch is still in adjustment. Mine did the same thing. It stopped working and I had to adjust the actuator that the spring attaches too. Not to hard to do, just turn the ring up or down. Turn it a little at a time and then push the brake a see if it works. But first, pull the little shaft and see if you can make the light work. if not then the switch is probably bad but check the fuse also.
 

·
Registered
Joined
·
31 Posts
brake lights wont work

FYI, I was having the same problem, brake lights not working turn signals not working, horn not working, fuses were good. believe it or not I replaced fuses, put them in proper order with proper amp loads , and sure enough they all worked again
I had checked the fuses none were bad just had wrong amp amounts never had a problem before with incorrect amps not working however this time seemed to make a difference
 

·
Registered
Joined
·
100 Posts
What if you're having the opposite problem?? I just snipped my license light off, now my brake light works when I hit the brakes, but not the running one. (I checked fuses too)
 
1 - 9 of 9 Posts
Top