Honda VTX 1300 / VTX 1800 Motorcycles Forum banner

1 - 10 of 10 Posts

·
Too short for my weight
Joined
·
5,654 Posts
Discussion Starter #1
So. I did this mod on my 1300 way back when. I’m wondering where you guys are putting the block on the 1800? Seems tighter than the 1300 on the tool box lid.... any suggestions? Pics?
 
  • Like
Reactions: sumdatx

·
Registered
Joined
·
17,021 Posts
Should have looked at mine @ the Pokey. I have mine double-stick taped to the tool box lid under my left side cover. Get the fuses that are EZ-ID, that light up when they pop.
 

·
Too short for my weight
Joined
·
5,654 Posts
Discussion Starter #3
I bought a small easy id style 6 space block that should fit on the tool box lid. It just seems tight.
 

·
Registered
Joined
·
17,021 Posts
Before pushing the female spade terminals on your circuits onto the male bladed contacts, shrink wrap over the female blade part to avoid accidental contacts.
 
  • Like
Reactions: sumdatx

·
Too short for my weight
Joined
·
5,654 Posts
Discussion Starter #5
Before pushing the female spade terminals on your circuits onto the male bladed contacts, shrink wrap over the female blade part to avoid accidental contacts.
Always! I went to autozone and picked up a dist box. Mounted it up tonight and started to set up trigger power for the relay when I realized I have the wrong connectors to into the factory plug. So I’ll go get those tomorrow and hopefully finish this up so I can wire in the led and the stereo.....

239955


It has a cover (not on it obviously) and each spade connector will be shrink wrapped and greased.
 

·
Mosin Prime
2019 Indian Roadmaster P3 Tail Light w/Photon Blasters Alert Diode DynamicsLEDs Adaptive2 Headlight
Joined
·
815 Posts
Mine was double sided sticky taped on to the toolbox door too! Worked awesome!
 

·
Registered
Joined
·
17,021 Posts
Always! I went to autozone and picked up a dist box. Mounted it up tonight and started to set up trigger power for the relay when I realized I have the wrong connectors to into the factory plug. So I’ll go get those tomorrow and hopefully finish this up so I can wire in the led and the stereo.....

View attachment 239955

It has a cover (not on it obviously) and each spade connector will be shrink wrapped and greased.
OOOH! Do those red lights light up if the circuit trips, or do they normally light and go out when they trip? Mine is pretty generic, but I use the specific EZ-ID fuses that will light up when tripped.
 

·
Too short for my weight
Joined
·
5,654 Posts
Discussion Starter #8
OOOH! Do those red lights light up if the circuit trips, or do they normally light and go out when they trip? Mine is pretty generic, but I use the specific EZ-ID fuses that will light up when tripped.
Don’t know, I haven’t put power to it yet.... I’ll let you know when I do!
 

·
Registered
Deplorable #2
Joined
·
6,703 Posts
Nice block there Sean, and you got it where ??? I may not have noticed o_O ..... I have one bolted to my tool box door, been there a long time. Been thinking about cleaning up all the wiring and a new box would be a good start, Tks (y)
 

·
Too short for my weight
Joined
·
5,654 Posts
Discussion Starter #10
Nice block there Sean, and you got it where ??? I may not have noticed o_O ..... I have one bolted to my tool box door, been there a long time. Been thinking about cleaning up all the wiring and a new box would be a good start, Tks (y)
I got it at autozone, I think it was about 8 bucks.
 
1 - 10 of 10 Posts
Top