Honda VTX 1300 / VTX 1800 Motorcycles Forum banner

1 - 12 of 12 Posts

·
Premium Member
Joined
·
1,591 Posts
Discussion Starter · #1 ·
Just installed a new battery. Now the right blinker is blinking like crazy whenever I activate it and the left one is at its normal blinking pace. Before the new battery was installed, both were blinking at their normal calm rates. What's up with that? Why would a new battery cause this? Should I replace the bulb or just feed the right blinker some ritalin?
 

·
The guitar, not the fish!
Joined
·
33,457 Posts
One of the bulbs burnt out...The decreased load on the system from a burnt out bulb makes the flash speed increase...Just a coincidence it happened when you changed the battery...
 

·
The guitar, not the fish!
Joined
·
33,457 Posts
One more thing...When installing the new bulb, CAREFULLY note the orientation of the "tits" on the sides..It's possible to install the bulbs 180* out of phase and they still won't work right..Why Honda didn't "idiot proof" them like car bulb sockets is beyond me...When I installed my lightbar, it took alot of head scratching before I figured out what the problem was...
 

·
Super Moderator
Joined
·
10,754 Posts
You could try switching the bulbs from left to right to see if it is the bulb. Watch out when you remove the lens of the turn signals. The turn signal housing has a delicate little plastic tab that can easily break. If it does, it cannot really be repaired and you have to replace the entire housing. To avoid breaking the tab first remove the screw on the bottom of the housing. Then squeeze the body of the turn signal housing together slightly from left to right. This elongates the opening in the housing where the lens fits. Then pull the bottom of the lens out slightly from the bottom of the housing. While still squeezing the housing, wiggle the lens as you pull further on the bottom of the lens. Eventually it will come out of the housing hopefully leaving the tab behind and intact.

G'day,

Vinish

Edit - Oops. While I was typing my note, you got better advice and implemented it. Glad it worked out to be a minor thing.
 

·
Premium Member
Joined
·
1,591 Posts
Discussion Starter · #6 ·
Rut-row Astro. Something's not working. The rear right blinker doesn't work. I tried oriented different ways like you said Bill. I looked at the working bulb on the left and matched that orientation. I even swapped the left and right bulbs.

It might be possible I knocked something loose when I installed the new battery. Anyone know which wires control the blinkers?
 

·
Premium Member
Joined
·
1,591 Posts
Discussion Starter · #8 ·
I love this place. I really do. Charlie, Bill, Vinish thank you very much. The blue wire leads were disconnected. All is well again in VTX land.
 

·
Registered
Joined
·
719 Posts
Dang!! How great is this forum? It is packed with great guys and terrific info. I am so freeking glad I found it.:cheers:
 
1 - 12 of 12 Posts
Top