Honda VTX 1300 / VTX 1800 Motorcycles Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 2004 VTX 1300C, it just turned 16,000 miles and have never had any issues. Yesterday I rode and made a couple of stops and when I continued to ride I noticed my speedo quit working and then it started working again for about 30 seconds and quit again. All my dash lights and odometers work. I've been told that I should check the the plug connections under the tank. I've also been told to check the speedo sensor. Can anyone tell me which one it probably is and if it's the speedo sensor how often do they go bad?
 

·
His Excellency
Joined
·
617 Posts
I had issues with the plugs under the tank. I was also getting reset tripometers, blank odo and no needle movement. If you aren't getting all that I'd say looking at the speed sensor might be your best bet. But just check those connections they are easy to get to and examine as a first step.
 

·
Dragon Slayer
Joined
·
8,515 Posts
Make sure battery connections are tight, use a wrench, not a screw driver, it's that or the plug harnesses under the tank. Does the trip odo reset itself when this happens?
 

·
Erect Member
Joined
·
11,583 Posts
i had speedo problems before...but some hairspray did the trick...kept them from riding up anymore and becoming thongs :eek:

first thing i thought of was the connector under the right front of the tank...green plugs, but looks like ct already mentioned it. i had my whole dash panel go out about 3 months after i bought the bike...but turned it off, then when i got on the next morning and was gonna go let the dealer look at it, everything was fine. knock on wood...havent had a problem since...
 

·
Registered
Joined
·
7,404 Posts
It's the green plugs in the black boot behind the black cover on the right front by the tree.
Sometimes they are not connected all the way. Careful the clip on the plugs break easily. If you have had the tank off sometimes the pins inside the plugs get pushed back in a little and don't make a good contact. You have to look very very closely and maybe even with a magnifying glass.
All dash info goes threw those plugs.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Thanks I'll check it out tomorrow, heading out on a 500 mile trip Thursday thought I might need the speedo!
 

·
No Reason To Be Serious
Joined
·
16,394 Posts
i had speedo problems before...but some hairspray did the trick...kept them from riding up anymore and becoming thongs :eek: QUOTE]


That stuff in the red can called, "Big Sexy Hair" is what I use for this... keeps 'em low and comfortable... just don't go over the parking lot speed bumps to fast... thats a real ball buster, for sure... Literally.... :nono:
 

·
Registered
Joined
·
7,404 Posts
If you put a zip tie threw the wires that will hold the connectors together - especially if the holding tab has been broken.
 
1 - 8 of 8 Posts
Top